You are logged in as a guest. 
  Home Forums Home  Search our Forums Search our Forums    Log in to the Forums Log in to the Forums  register Register on the Forums  

 Forums ->  Motorhomes -> Motorhome Matters
Jump to page : First 1 Last
Format:  Go
06 Dethleffs motorhome not running
AuthorMessage
userbarbaraduggan3
Posted: 31 July 2020 4:47 PM
Subject: 06 Dethleffs motorhome not running
 
Just joined

Posts: 3



Hi,
We have an 06 Dethleffs Esprit Motorhome with a Renault Master chassis which has been in the garage for over a year. It suddenly broke down on a trip. Difficult to start when cold,won't rev properly when in gear. Had egr valve checked,injectors checked,pressure relief checked,CPU checked and clock panel checked. Anyone have any ideas? Working on the wiring at the moment.
Thanks.
userDen
Posted: 31 July 2020 5:25 PM
Subject: RE: 06 Dethleffs motorhome not running
 
Treasured contributor

Posts: 888
500100100100252525
Location: Worcester


Renault Masters have been my favourite commercial vehicle for years.
The last one a 16 seater had problems.
Not running properly and the auto box juddered on take up.
After being off the road for 6 weeks and Renault uk being involved and finally Renault France, they still couldn’t sort the problem.
I suggested on several occasions the ECU.
They did not want to fit one due to cost and setting it up afterwards.
Finally they fitted a new ECU and it started and run perfectly.
Renault are still my favourite and Mercedes are now using several of the Renault platforms and rebadging them Mercedes.
userbarbaraduggan3
Posted: 31 July 2020 5:48 PM
Subject: RE: 06 Dethleffs motorhome not running
 
Just joined

Posts: 3



Thanks. Will pass that on to garage.
userweldted
Posted: 31 July 2020 11:43 PM
Subject: RE: 06 Dethleffs motorhome not running
 
Pillar of the forums

Posts: 711
500100100
Location: Burstner Ixeo 736


Not very common, but have you checked the exhaust is clear? Over the years I’ve come across it where when the vehicle has been stood for a long time the silencer has collapsed inside and blocked up
userbarbaraduggan3
Posted: 31 July 2020 11:55 PM
Subject: RE: 06 Dethleffs motorhome not running
 
Just joined

Posts: 3



Thank you. Will check.
Jump to page : First 1 Last
Printer friendly version
E-mail a link to this thread
Jump to forum :


(Delete all cookies set by this site)(Return to Homepage)

Any problems? Contact the administrator