You are logged in as a guest. 
  Home Forums Home  Search our Forums Search our Forums    Log in to the Forums Log in to the Forums  register Register on the Forums  

 Forums ->  Motorhomes -> Motorhome Matters
Jump to page : First 1 2 Last
Format:  Go
Help! Thetford fridge problem
AuthorMessage
userMickydripin
Posted: 30 July 2013 5:42 PM
Subject: Help! Thetford fridge problem
 
Lives on the forums

Posts: 554
5002525
Location: Staffordshire


Hi all,
I noticed today that my SES fridge is running on gas I am on electric hook up but it will not work on that.
I switch it on and it says Auto and goes to 230v plug ten seconds later it switches to the gas flame.
When I do it manually and put it on 230v plug ten seconds later the blue light starts to flash and on the right a spanner symbol comes on.
It shows that the power is on on the mains board and I have checked all the fuses that I know of can anyone give me a clue what is wrong.
userlennyhb
Posted: 31 July 2013 11:57 AM
Subject: RE: Help! Thetford fridge problem
 


Lord of the posts

Posts: 5852
50005001001001002525
Location: West Sussex: Hymer B678 Dynamic Line, 150hp Auto


Could be the mains element has failed or the voltage is too low. You do do not say where you are if you are France or Italy it would not surprise me if the mains voltage is below the required 200V.

From the Thetford manual:-

"5.3.1 Auto mode
Mains voltage (230 V):
This energy source will be selected if the mains voltage is greater than 200 V. This
power supply requires a continuous current of 12 V to operate the electronic
control system."

"If a fault occurs in one or more of the possible energy sources, the system will not
generate an error message while an alternative energy source is still available. The
SES system switches over automatically.
If none of the energy sources are available, the blue LED flashes every second and
an error code is shown in the display.
Automatic models additionally allow you to select the desired energy source
manually."

"Mains voltage (230 V):
The LED warns you whenever insufficient voltage is available or if a fault occurs. If
this happens, the LED will start flashing once per second and an error code is
shown in the LCD display.
When sufficient current is available again, or the fault has been resolved, the LED
will emit a steady blue light again."


userbolero boy
Posted: 31 July 2013 1:15 PM
Subject: RE: Help! Thetford fridge problem
 


Epic contributor

Posts: 1707
1000500100100
Location: Somerset 2017 Carthago C-Compactline i138


I've had some problems myself like this which resulted in a new fridge. This also had a problem, coming up with error 1.
When I discussed this with the dealer he said I was reading the error codes from an old manual as the new fridge was different/upgrade.......
What error code do you have next to the 'spanner' symbol? I now have the new docs with the code translations.
userMickydripin
Posted: 31 July 2013 1:17 PM
Subject: RE: Help! Thetford fridge problem
 
Lives on the forums

Posts: 554
5002525
Location: Staffordshire


Hi Lenny,
I knocked the power switch off in the van and started the engine to see if the fridge works on the batteries and it did no problem.
I stopped the engine and turned the power switch on again I then pressed the button to put it on auto and it went to gas I then manually pressed the button to work on 230v and it worked I left it for a minute and put it back on auto and it went to 230v for about 3 minutes and then went back to gas.
What a pain.
And yes I am in France.
what confuses me is that the air con works fine I have tried to switch the air con off for a while to see if that was taking the power but that was not the problem.

Mike
userDerek Uzzell
Posted: 31 July 2013 2:11 PM
Subject: RE: Help! Thetford fridge problem
 


50005000500020001000500100100100
Location: MODERATOR - 2015 Rapido 640F LHD 2.3ltr 150bhp


This earlier forum thread discusses a similar situation:

http://www.outandaboutlive.co.uk/forums/Motorhomes/Motorhome-Matters/thedford-ses-fridge-problem/23450/

Tips on Thetford fridge trouble-shooting are here:

http://www.swift-owners-club.com/support/oem_handbooks/thetford/troubleshooting_fridges.pdf

From what Bolero Boy says, the information about Error Codes may be out of date but, as your fridge is showing a spanner-symbol, it would be logical to expect there to be an Error Code too. If there is an Error Code showing, what Error Code number is being displayed?

As Lennyhb advises, the voltage of your campsite's power-supply may be below the level necessary for the fridge to operate satisfactorily on mains electricity. To check this you'd need to measure that voltage as mentioned in the trouble-shooting guide. I don't think the fact that your air-conditioner works OK would be a reliable indicator that the campsite's voltage is high enough to run your fridge, nor do I think that switching the air-conditioner off will help diagnosis. You actually need to measure the voltage with a voltmeter.

You could try swapping to another outlet on the supply-pedestal ('borne') to see if that would do any good. I've also seen it suggested that pulling out all the fridge fuses, waiting a while (say 30 minutes) and then replacing the fuses may cause the fridge's electronics to 'reboot'. But, If the campsite's mains supply voltage is too low, there's really nothing you can do about that yourself.

If you can find someone with a mains generator that (hopefully!) will produce a full 230V supply and connect your motorhome to that generator just to test the fridge, you may be able to say whether the problem is due to low voltage. If the fridge will run from the electricity produced by the generator, then the campsite's power-supply is probably the culprit. If the fridge will NOT run from the electricity produced by the generator, then it's more likely there's a fault with the fridge itself.
usermildi
Posted: 31 July 2013 2:35 PM
Subject: RE: Help! Thetford fridge problem
 
Gets involved

Posts: 296
100100252525
Location: Charente, France Adria Coral 660 SP


I have the same problem, more or less, on site in France and temp in the 30s.
On electric (6amp) found that the auto on ses fridge switches to gas and back to electric every few seconds. Try to put fridge on electric but comes up error 8 (20% below normal power) site electrics are a mix of 3 & 6 amp and very temperamental. Gave up, run on gas during day and fitted a fan kit to top vent, fridge runs great and can make ice, turn back to electric at night just to save gas as not many using electric till the morning then hey!! it switches to gas as all the brits make tea.
Mark.
userlennyhb
Posted: 31 July 2013 2:44 PM
Subject: RE: Help! Thetford fridge problem
 


Lord of the posts

Posts: 5852
50005001001001002525
Location: West Sussex: Hymer B678 Dynamic Line, 150hp Auto


Might we worth a trip to the nearest Hypermarket and pick up a cheap multimeter usually about 5€ then check the mains voltage.

Or just run on gas and see what it does when back in the UK. If it's above 25 deg where you are the fridge will work better on gas anyway.
userMickydripin
Posted: 31 July 2013 11:03 PM
Subject: RE: Help! Thetford fridge problem
 
Lives on the forums

Posts: 554
5002525
Location: Staffordshire


I've had some problems myself like this which resulted in a new fridge. This also had a problem, coming up with error 1.

I think the error code is 1 or it looks like a slash I hope it does not mean a new fridge as I am just over the two years warranty and only use it in the summer sod`s law is it not.

Mike.
userMickydripin
Posted: 31 July 2013 11:03 PM
Subject: RE: Help! Thetford fridge problem
 
Lives on the forums

Posts: 554
5002525
Location: Staffordshire


I've had some problems myself like this which resulted in a new fridge. This also had a problem, coming up with error 1.

I think the error code is 1 or it looks like a slash I hope it does not mean a new fridge as I am just over the two years warranty and only use it in the summer sod`s law is it not.

Mike.
userMickydripin
Posted: 31 July 2013 11:03 PM
Subject: RE: Help! Thetford fridge problem
 
Lives on the forums

Posts: 554
5002525
Location: Staffordshire


I've had some problems myself like this which resulted in a new fridge. This also had a problem, coming up with error 1.

I think the error code is 1 or it looks like a slash I hope it does not mean a new fridge as I am just over the two years warranty and only use it in the summer sod`s law is it not.

Mike.
userDerek Uzzell
Posted: 1 August 2013 7:09 AM
Subject: RE: Help! Thetford fridge problem
 


50005000500020001000500100100100
Location: MODERATOR - 2015 Rapido 640F LHD 2.3ltr 150bhp


Some other suggestions here:

http://www.motorhomefun.co.uk/motorhome-chat/65935-fault-thetford-fridge.html

Based on Thetford's advice, Error Code 1 has four possible causes:

1. Low voltage AC power-supply.
2. Failure of 5Amp fuse.
3. Failure of AC heater.
4. Fault with power-control board.

On another website it's advised that the 5Amp fuse may be accessed if the exterior ventilation-grille (presumably the lower grille) is removed. Also that it would be worth removing the lower ventilation-grille to see if the fridge has a 3-pin plug on it to supply AC power to the appliance. If there is a plug/socket, the fuse may have failed and/or there may be a bad connection.

(Are you sure your Thetford fridge only has a 2-year warranty? I had a feeling Thetford fridges might have a 3-year warranty, but with the terms and conditions for maintaining the warranty's validity being pretty strict.)
userbolero boy
Posted: 1 August 2013 9:02 AM
Subject: RE: Help! Thetford fridge problem
 


Epic contributor

Posts: 1707
1000500100100
Location: Somerset 2017 Carthago C-Compactline i138


Error code 1 on our new fridge is 'senses flame when gas should be off'. This is on a N300 model.
There is a troubleshooting section (aimed at service agent, i suspect) which goes like this.....

Turn fridge on and off. Solved, great!
Not solved, check if gas valve works. No, replace valve.
Yes, is production date before 1/1/2013 no, replace power board assembly.
Yes, replace power board assembly and display board.

Our dealer did neither of these things.....they got it working (by showing me how to fully remove the power as just turning it off is not sufficient) and said try it for a bit longer.....

It appears to be working on gas and on 12v as I can test these easily, haven't bothered with testing EHU yet. May do later.
userMickydripin
Posted: 1 August 2013 12:18 PM
Subject: RE: Help! Thetford fridge problem
 
Lives on the forums

Posts: 554
5002525
Location: Staffordshire


(Are you sure your Thetford fridge only has a 2-year warranty? I had a feeling Thetford fridges might have a 3-year warranty, but with the terms and conditions for maintaining the warranty's validity being pretty strict.)
-----------------------------------------------------------------------------------------

Hi Derek thanks for that I did not know what warranty it had I hope it is three years I have contacted Thetford but had no reply yet.
My servicing is well up to date so there should be no problems there been looking for a Thetford agent Nr les Sables d`Olonne in France but no luck so far.

Thanks all for all your help.

Mike.
userDerek Uzzell
Posted: 1 August 2013 1:28 PM
Subject: RE: Help! Thetford fridge problem
 


50005000500020001000500100100100
Location: MODERATOR - 2015 Rapido 640F LHD 2.3ltr 150bhp


According to Thetford's website

http://www.thetford-europe.com/en/dealers.aspx

these are dealerships/service centres fairly close to you. (Select France and type in olonne)

This dealership is nearest and shown on the map as being on the D2949 leaving the south-east part of Sables-d'Olonnes towards Talmont-Saint-Hilaire

1. Stop Accessoires
181 Avenue De Talmont
85180 Chateau D'Olonne
France
T +33 2 51328556

These 4 dealerships are grouped around La Roche-sur-Yon

2. Vendée Loisirs
La Landette Sud
85430 Les Clouzeaux
France
T +33 2 51403818

3. Le Monde Du Camping Car 85 (Destinea)
Route Des Sables
85430 Les Clouzeaux
France
T +33 2 51403031

4. Plein Air Service 85
Za Du Chaillot
85310 Nesmy
France
T +33 2 51626413

5. Mobiloisir (Top Accessoires)
Parc D'Activité
85190 Venansault
France
T +33 2 51059707

This one is shown on the map as a Thetford Service Centre (so might be your best bet). It's on the D763 a few kilometres north of La Roche-sur-Yon

6. Roche Evasion
ZI De L'Eraudiere
85170 Dompierre Sur Yon
France
T +33 2 51362585

The Roche Evasion website is here:

http://rocheevasion.fr/
userMickydripin
Posted: 1 August 2013 10:47 PM
Subject: RE: Help! Thetford fridge problem
 
Lives on the forums

Posts: 554
5002525
Location: Staffordshire


Hi Derek,
thanks very much for the info I will try the one closest first I will let you know how I get on but first I want to know if my fridge has a three year warranty.

Mike.
userBrian Kirby
Posted: 2 August 2013 12:05 AM
Subject: RE: Help! Thetford fridge problem
 


5000500050002000100025
Location: East Sussex. Motorhome: Knaus Boxstar 600 Street


Hi Mike.

Ours is a Thetford (2013) and the warranty is stated in the handbook to be three years. The conditions are, broadly, that it has not been misused, that it was originally built into a motorhome or caravan, that it has its original serial No etc, that it has not been altered, and that it has the correct power supplies etc. Not very onerous, so should be complied with on yours.
The only question is whether the warranty has recently been changed to three years, and possibly whether you can prove in France when the van was first registered.
However, if the agent can fix it, I assume he will either check the warranty status, or will charge you for the repair which you should be able to reclaim from Thetford in some way. Make sure you get a receipt! It might be a good idea to put Thetford on notice beforehand that you are going to the French agent in the hope he will make repair under warranty. You may have a bit of a problem with responses from Thetford or the agent at present because of staff holidays/shutdowns. Good luck!
userDerek Uzzell
Posted: 2 August 2013 8:07 AM
Subject: RE: Help! Thetford fridge problem
 


50005000500020001000500100100100
Location: MODERATOR - 2015 Rapido 640F LHD 2.3ltr 150bhp


Here's the 2008 thread that originally referred to the Thetford warranty:

http://www.outandaboutlive.co.uk/forums/Motorhomes/Motorhome-Matters/Thetford-fridge-warranty/12936/#M130767

Bolero Boy's Error Code 1 relates to a gas problem. It's quite possible that the Error Codes for current-model N300 fridges differ from earlier Thetford appliances or other fridge models. Anyway, as Mike's fridge refuses to run on AC power, the Error Code 1 his fridge is displaying should, logically, apply to an AC-related problem.

Before getting involved with Thetford warranty duration, validity and claiming for repairs, it would be simple commonsense to check that the problem isn't exactly what the Error Code 1 seems to warn about - that the campsite's power-supply voltage is too low.

As lennhb says, testing this theory should be easy enough with a cheap voltmeter but, if that's impracticable, before running up a bill with a French motorhome dealership it would be sensible to ask the dealership to confirm how the fridge reacts when connected to the dealership's own mains power-supply. There is, of course, the small possibility that the voltage of the French dealership's power-supply would also be sub-standard, but - if the fridge runs OK from another mains power-supply - there should be no need to explore further.

For what it's worth, UK prices for a Thetford fridge AC heater are around £40, and for a power-control board around £130. The heater and board differ according to the fridge model and its age, and the prices vary accordingly. If a heater or power-control board needed to be replaced, it might well be necessary to remove (or at least displace) the fridge to allow this to be done, with consequential labour costs.
userBrian Kirby
Posted: 2 August 2013 3:05 PM
Subject: RE: Help! Thetford fridge problem
 


5000500050002000100025
Location: East Sussex. Motorhome: Knaus Boxstar 600 Street


Derek Uzzell - 2013-08-02 8:07 AM..............Before getting involved with Thetford warranty duration, validity and claiming for repairs, it would be simple commonsense to check that the problem isn't exactly what the Error Code 1 seems to warn about - that the campsite's power-supply voltage is too low. ...................

Very much agree with this. Voltage drop on full continental sites is quite common, especially where the supplies are limited to 5/6A. Full site with high temperatures means everyone's fridges are running flat out, and others will be running fans etc as well - plus those French holidaymakers who bring their domestic fridge and stick it in the awning! It isn't that they overload their individual supplies, just that collectively everyone is working the distribution system flat out, and the cables aren't really up to the load, so voltage falls.

Another trick may be to see what the fridge does at night, when the overall load should have reduced. The voltage may then, as suggested above, creep back up to allow the fridge to run off mains. If it is OK at night it is OK, and is just doing as it should.

The main breakers etc are presumably somewhere around the main reception building, so you might be able to get a higher voltage if you can change to a pitch a bit nearer to where the circuits originate, especially if you are presently on (or near) the end of the line.
userMickydripin
Posted: 6 August 2013 2:08 PM
Subject: RE: Help! Thetford fridge problem
 
Lives on the forums

Posts: 554
5002525
Location: Staffordshire


Hi all,
An update for my Thetford fridge.
I went to the dealers in Les Sables D`Olonne that Derek listed no use at all could not speak a word of English and was not interested at all just waved me off.
Then I rang the other dealers in La Roch Sur Yon the same there
Now I will wait until I get home next month to sort it out it will just have to run on gas not Ideal but I still have a cold fridge.
Thanks all for your help.

Mike.
userWillowmarsh
Posted: 25 May 2014 5:45 PM
Subject: RE: Help! Thetford fridge problem
 
Just joined

Posts: 2



I am presently in France with the same problem as Mickydripin . My Thetford fridge will not work on electricity. I emailed Thetford and was given list of their service agents in France. The Fremch site manager has contacted three of them for me, but they do not want to know. I have cut my holiday short to return to UK to get it fixed. Thetford after-sales service is very disappointing. Can anybody who has had this problem tell me how it was resolved? Thank you.


Edited by Willowmarsh 2014-05-25 5:48 PM
userMickydripin
Posted: 25 May 2014 8:29 PM
Subject: RE: Help! Thetford fridge problem
 
Lives on the forums

Posts: 554
5002525
Location: Staffordshire


Hi Willowmarsh.

I was confused at first when I saw this post until I went to the bottom of the postings Yes I had this problem and I had the circuit board changed have you washed your van and let the water go in the outside vents or have you been in any very bad rain whilst driving as that could have got in to the box that encloses the circuit board just open it very carefully and check for water ingress if it has it may have blown the board.
Before going for a new board,
If wet try drying it with a hair dryer then put some Vaseline on the edges before you close it up again.
Make sure that you disconnect all power to the box 12V and 240V before you open it.
If it is not that it could be the element in the Flue that is causing your problems.
When I opened my circuit board box it was soaking wet and I do not know if that caused it to blow the element in the flue as well as they said that they changed both.
If your van is less than three years old you are covered by the warranty.

I hope this works for you, Mike

Edited by Mickydripin 2014-05-25 8:36 PM
userWills Wagon
Posted: 26 May 2014 6:03 PM
Subject: RE: Help! Thetford fridge problem
 


A posting machine

Posts: 309
100100100
Location: AutoTrail V Line 635 SE July 2017


We had a problem like this at a UK Caravan Club site in December and last week in France. All works OK on gas and battery but blue light flashes when on hook-up, so the problem is most probably the AC supply. Ours is an SES fridge dated 2011. The spanner code 8 comes up which indicates AC current is 20% below normal. I changed to another socket on the same bollard and mains worked normally. I don't understand French wiring either but the fridge works OK now and has done on the five other sites we have used in France which have had 5 -15 Amp supplies.
userWillowmarsh
Posted: 26 May 2014 7:37 PM
Subject: RE: Help! Thetford fridge problem
 
Just joined

Posts: 2



Many thanks for your suggestions. Still in France and will look into your suggestions when I can get my hands on some small steps. Have now run out of gas. Tried another Thetforrd service agent today and given the same disinterested reaction.
userfordsrv
Posted: 5 June 2014 2:28 PM
Subject: RE: Help! Thetford fridge problem
 
Just joined

Posts: 1



hello all,
I am a technician at Ford's RV Refrigeration and Training Center. Go to YouTube, we have around 19 videos that cover from refrigerator basics to some of the more technical stuff. I am sure you can find your answer there. Or go to our website www.rvrefrigeration.com. we just launched our in-depth online training and we are offering a chance for someone to win it for free monthly, just go to the website and apply absolutely no charge to apply for a chance to win.
userhallii
Posted: 5 June 2014 4:19 PM
Subject: RE: Help! Thetford fridge problem
 


Epic contributor

Posts: 1595
1000500252525
Location: Worcestershire Hymer Van 522 2007


My Thetford would not run on mains on a French campsite, blue flashing light every time I tried.
It turned out that the mains was reversed. It worked fine at the next campsite.

H

PS I still can't find the interior light reed switch and Thetford haven't replied to my email.
userips
Posted: 6 June 2014 1:05 PM
Subject: RE: Help! Thetford fridge problem
 


Epic contributor

Posts: 1853
10005001001001002525
Location: Lancashire


I had similar problem a few weeks ago, blue flashing light and not working, plugged the lead into another outlet but on the same bollard and it worked fine. I think its down to low voltage casued by bad connections somewere.
userhallii
Posted: 6 June 2014 3:35 PM
Subject: RE: Help! Thetford fridge problem
 


Epic contributor

Posts: 1595
1000500252525
Location: Worcestershire Hymer Van 522 2007


hallii - 2014-06-05 4:19 PM

My Thetford would not run on mains on a French campsite, blue flashing light every time I tried.
It turned out that the mains was reversed. It worked fine at the next campsite.

H

PS I still can't find the interior light reed switch and Thetford haven't replied to my email.


Oh joy! The fridge light fairies have woken up and are now turning my light onand off like they should.

Mrs H had quite a squeeze fitting into the frdge to check it was going out.

I just hope the fairies don't go on strike again, I think it is likely.

H
userMargus
Posted: 23 October 2014 6:10 AM
Subject: RE: Help! Thetford fridge problem
 
Just joined

Posts: 3



I had a problem with the fridge when it would not work after it had a couple dissconnections and reconnections from the mains. I think its brains went just nuts after switching on and off the gas too many times in short time . No help from the manual. I went outside and opend the fridge vent hatch. dissconnected both cables. it worked like total restart. I have had that kind of problem twice for now. both times the same solution.
userbolero boy
Posted: 23 October 2014 8:03 AM
Subject: RE: Help! Thetford fridge problem
 


Epic contributor

Posts: 1707
1000500100100
Location: Somerset 2017 Carthago C-Compactline i138


Margus - 2014-10-23 6:10 AM

I had a problem with the fridge when it would not work after it had a couple dissconnections and reconnections from the mains. I think its brains went just nuts after switching on and off the gas too many times in short time . No help from the manual. I went outside and opend the fridge vent hatch. dissconnected both cables. it worked like total restart. I have had that kind of problem twice for now. both times the same solution.


this disconnection of power also worked for us....we are still getting the odd 'confused' moment even on our new replaced fidge/freezer.
however, I was wondering if this 'disconnection' can be achieved by powering down the Sargent PSU and killing all 12v.....?Saves going outside to open Tthe vent, though it doesn't take a minute when you've done it a few times...
userStuartO
Posted: 23 October 2014 8:42 AM
Subject: RE: Help! Thetford fridge problem
 


Forum master

Posts: 4455
200020001001001001002525
Location: Suffolk, Hymer B674 2006


Excellent thread this. Well done all contributors.
Jump to page : First 1 2 Last
Printer friendly version
E-mail a link to this thread
Jump to forum :


(Delete all cookies set by this site)(Return to Homepage)

Any problems? Contact the administrator