You are logged in as a guest. 
  Home Forums Home  Search our Forums Search our Forums    Log in to the Forums Log in to the Forums  register Register on the Forums  

 Forums ->  Motorhomes -> Motorhome Matters
Jump to page : First 1 Last
Format:  Go
I'm not in hot water
AuthorMessage
userCruisecontrol
Posted: 25 March 2021 9:44 AM
Subject: I'm not in hot water
 


Pops in from time to time

Posts: 108
100
Location: Chandlers Ford, Hants


The reason for this is the failure of the Truma Combi to heat water when gas is selected as the power source. The van is a 2016 Burstner Nexxo Sovereign 690G.

With cab air heating switched off and water heating with gas is selected the Combi fires up but switches off after 2 minutes. No fault code is displayed and the three LEDs on the boiler remain lit.

Water can be heated by selecting electric. Also room temperature and water heating work on both power sources ( the water being heated by gas in this latter case is obviously due to the Combi heating the water reservoir as it heats the exchanger).

Truma don't have an answer but point to a circuit board or a gas valve. The latter being unlikely due to the 2 minute cut out I'd think.

The van is with Whispaire in Romsey, an excellent firm I've used before and a Truma agent. I think I'm going to need deep pockets!

Has anyone experienced this or have suggestions?


userthebishbus
Posted: 25 March 2021 10:14 AM
Subject: RE: I'm not in hot water
 


Epic contributor

Posts: 1224
1000100100
Location: Warwickshire 01 Hymer 584


That does sound unusual. I had mine cutting out on gas after 1 to 2 minuets, caused through debris in the in the concentric inlet/outlet pipes .I disconnected them from the outlet fitting and sucked through them with a powerful vacuum cleaner ,amazing what came out .
Brian B.
userCruisecontrol
Posted: 25 March 2021 10:33 AM
Subject: RE: I'm not in hot water
 


Pops in from time to time

Posts: 108
100
Location: Chandlers Ford, Hants


Thanks Brian, I'll look at that but it does work on hot air with gas selected. Weird!
uservindiboy
Posted: 25 March 2021 11:28 AM
Subject: RE: I'm not in hot water
 
Epic contributor

Posts: 1806
1000500100100100


Cruisecontrol - 2021-03-25 9:44 AM

The reason for this is the failure of the Truma Combi to heat water when gas is selected as the power source. The van is a 2016 Burstner Nexxo Sovereign 690G.

With cab air heating switched off and water heating with gas is selected the Combi fires up but switches off after 2 minutes. No fault code is displayed and the three LEDs on the boiler remain lit.

Water can be heated by selecting electric. Also room temperature and water heating work on both power sources ( the water being heated by gas in this latter case is obviously due to the Combi heating the water reservoir as it heats the exchanger).

Truma don't have an answer but point to a circuit board or a gas valve. The latter being unlikely due to the 2 minute cut out I'd think.

The van is with Whispaire in Romsey, an excellent firm I've used before and a Truma agent. I think I'm going to need deep pockets!

Has anyone experienced this or have suggestions?

Your problem will be sorted by Whispaire in Romsey, I have used him [ Martin ] several times great service and knows his stuff , problem is he is a one man band and can get very busy, I had problems with a Combi in my ex Hymer electric collar failed and on gas the boiler was getting too hot and melting the plastic surround of the casing, he sorted all that and also the thermostat for the space heating failed , he fixed that, I also needed a new fridge freezer in my now Chausson and he did that after trying to get my old one to work but it had gone too far, I had to remove my front seats from the van and the table to get the new fridge into the van as it would not go through the habitation door , he was happy for me to that and it saved me a few hours on the labour costs , So a man I would recommend to any one, You could also stay overnight on the premises or nearby on the estate at a pinch whilst your van was in dock., he is very fair I think in what he charges too.
userDerek Uzzell
Posted: 25 March 2021 1:39 PM
Subject: RE: I'm not in hot water
 


5000500050005000
Location: MODERATOR - 2015 Rapido 640F LHD 2.3ltr 150bhp


Cruisecontrol - 2021-03-25 9:44 AM

...Truma don't have an answer but point to a circuit board...

As good a remote diagnosis as any. If the problem were being investigated in the Truma(UK) workshops, the logical initial step would be to try a new PCB.
userCruisecontrol
Posted: 2 April 2021 2:15 PM
Subject: RE: I'm not in hot water
 


Pops in from time to time

Posts: 108
100
Location: Chandlers Ford, Hants


Tail piece
The Truma 6 boiler was repaired by Whispaire of Romsey
Martin, the owner, trialled replacements of the temperature sensor and the PCB - No change.
Other checks made but finally the boiler was removed and the gas water heating valve was changed.
Apparently the boiler, on gas selected, goes through 3 stages for air heating and 2 for water only. Stage 2 was failing on water. On air (plus water) it bypassed stage 2. So it seemed it was heating the water but in practice it would not have got completely hot. As reported before - no fault codes shown.
Finally; I'm glad we maintained the MBG warranty payments. It was quite a heavty bill!
We just need the freedom to use the van now - no sunny Spain this year though!
Jump to page : First 1 Last
Printer friendly version
E-mail a link to this thread
Jump to forum :


(Delete all cookies set by this site)(Return to Homepage)

Any problems? Contact the administrator