Jump to content

Habitation electrics not working - CI Carioca 656 2006


Recommended Posts

I have a problem with my control panel not working on my Carioca 656 2006 model (06). I'm just getting red lights flashing when I press the battery button and no lights and no pump and this is the same whether I plug into the mains or try to run off the leisure battery. The starter battery is fine as I've been driving and the leisure battery isn't the problem as I've been into Halfords and tried a new one.


I've tried disconnecting the battery to reset everything for 5 minutes and have tried disconnecting the cable on the back of the control panel to try and reset it that way.


I'm away at the moment, and just wondering if someone could give me an idiots guide to how to bypass the control panel to get the pump and ideally the lights working again. If only the pump can be bypassed as mentioned in the thread above that would help a lot to get me through the next week!


Hope someone can help please.


Link to comment
Share on other sites

  • 1 month later...
Thanks. It turned out to be the fuse board behind the driver's seat had gone. Put a new one in and that fixed it. CI dealers were quoting 6 week delivery times for the carioca fuse board or the carioca control panel, but I've managed to source both much quicker now from Italy.
Link to comment
Share on other sites

  • 2 years later...


This topic is now archived and is closed to further replies.

  • Create New...