Jump to content

Citroen Relay X250 Immobiliser problems


Recommended Posts

Hi Folks!


New on here and, having surfed around a bit looking for a solution to my immobiliser problem, am posting in the hope that others more expert can advise. Here's the background...


About 4 months ago we bought a low mileage 2009 Citroen Relay minibus to convert ourselves (previously had 'pop-topped' a Vivaro which was great, but a bit too small for the family and two dogs!). Everything was great with the Citroen until we took it in to Tom Farmer Autocare to get the original tyres changed for snow tyres.


The van was with them for 3-4 hours and when we went to pick it up the immobiliser light came on and we couldn't get it started. Having left it with them overnight (was gone 5pm on a Sunday) we eventually got it started the next morning, but it was a bit 'flaky' and I think I was just lucky to get it going.


On the way home the heater fan stopped working, but I later discovered it would work on maximum in position 4. The van itself worked okay for a couple more short local drives, and I took it out for a longer one to fully recharge the battery as well, but then the same problem returned.


I got it booked in to the local Citroen dealer for an investigation, and they diagnosed a faulty connector to the blower resistor, and three occurrences of "interference on the loom" possibly affecting the immobiliser. Quoting ridiculous costs for 'replacing the loom' I took the vehicle away determined to sort the problem myself - with the assistance from Google obviously. (I should mention at this point that I am an engineer and previously managed to restore the abraded and corroded loom of the 12 year old 170,000 mile Vivaro to health, so am not daunted by the challenge!)


Upshot is that as of the last two weeks the immobiliser light is now permanently on and though the van cranks just as before, it does not let itself start. In those two weeks I've trawled the internet and sorted the following:


1. Checked all the fuses in all three locations, and on top of the battery +ve as well. All fine. (The fan fuse wasn't blown).


2. Replaced the the filthy pollen filter, the faulty blower resistor and the overheated multi block connector to it. The fan is now running fine at all speeds.


3. Cleaned up the earth strap connections, as well as adding a second 'tinned & sealed' Halfords earth strap in the same position. (The engine-body resistance wasn't high before though, <1 ohm).


4. Replaced the original battery with a brand new Yuasa - the 'Fiamm' one in the van was original and on its way out (6-7 yrs old, affected by the colder weather, tops of the plates visible in 4 of the 6 cells, and voltage down around 11.2V).


Now the fan works fine on all speeds, and the van cranks like a trojan with the new battery, but none of that has changed the immobiliser issue.


Before I take the nearside headlight out and get down into the nitty-gritty of the 'rusty plug' or a wire-by-wire inspection of that rubbish loom as per other threads, is there anything else I should be trying just now that could be an easier cure? What is the likelihood that the immobiliser bit of the ECU is fried??


Lastly I should say that the van (only 29,500 miles) has worked perfectly until it was in the for the tyres. I have been doing some mods at the back (adding a reversing camera and reverse parking sensors) which may explain the "interference on the loom" result from Citroen, but maybe this could have been caused too by the blower multi-block arcing as it was overheating and failing(??). Also the battery was probably at a low state of charge when it went for tyres, and I imagine the guys there had the doors open (i.e. courtesy lights on) for some time while they did the tyre swap (I provided the snow tyres rather than buy theirs so they were in the van, not coming off TFA's shelves). However, it cranked okay at the time and obviously did start in the morning without further charging.


The last 'weird bit' worth mentioning was that in checking the oil before I took it down to TFA, I noticed that quite a lot of water dropped out of the cabin air intake box on the underside of the bonnet, this because it was partially clogged with leaves that had fallen in through the grill on the top. The water then fell onto the air filter housing and splashed around below that, including on the aforementioned loom, which seems to permanently have a drip hanging from the low point of the loop.


From all I've read on these forums I'm thinking that I need to check the wiring to the key barrel sensor first, check the 'rusty junction' multi-plug for poor connections second, and maybe peel back the loom below it to inspect the cables there for issues as third. As much fun as this sounds (not), it is Christmas and I don't want to have to spend the entire time out on the driveway fixing electrics in the rain. I'll happily take any advice or tips this wise forum has to offer to help me get it sorted!


Finally, I don't think I really worked this out from the forums, will the emergency start procedure work for this van with it's 2.2 Puma engine??


Many thanks in advance - and apologies for the enormous first post. Promise I'll be briefer in future! ;-)



Link to comment
Share on other sites

ChamFan - 2015-12-22 12:46 AM

What is the likelihood that the immobiliser bit of the ECU is fried??


Your problem does sound very similar to the broken down wire in the loom that I had with my 2008 X2/50 - you'll have no doubt already found that thread with its pictures as part of your research.


When you turn on the ignition do you hear relays click and the low pressure fuel pump start to whirr or is it all very silent? If the latter then I'd take this as an indication that the immobiliser isn't receiving the correct signal due to wiring faults rather than it being 'fried'.

Link to comment
Share on other sites

HI Steve and thank for coming back.


Yes I found that thread - that's what worries me! Fine to intermittent to complete failure does sound like a deteriorating wire as others have said. Excellent diagnostics and write-up by the way!


I also just tried starting the van again and it is complete silence as far as relays and fuel pump are concerned. That's reassuring it probably it isn't the immobiliser on the ECU!


Time to start hunting!

Link to comment
Share on other sites

Just a thought.....


If the garage ran the battery very low and jump started it; there is a possibility that the CAL5 fuse on the battery is damaged. It may seem OK but have a high resistance. It is the large black one on the top of the battery, by the positive terminal. You can probably still only get them from Fiat/PSA dealers.


If you are getting nothing at all when attempting to start, this is often the cause and while these fuses are not cheap; it's easier than going through every last wire in the loom!


Do you have a spare key? Have you tried it? It was the only detail omitted from your report if you did.



Link to comment
Share on other sites

The garage guys told me they didn't jump it and anyway the CAL-5 fuse tests fine and the engine cranks well. I've also tried both keys with no joy.


Now Christmas is over I've had a chance to get back into it and have had the headlight out and inspected the entire loom from below the windscreen to all the individual connector blocks. It was wet and dirty in places, but no visible sign of any breaks or inconsistencies, including the white/orange wire to the ECU. Once rebuilt it was the same issue with the immobiliser, so I am starting to look for other things.


To help with that I now have a DiagBox/Lexia3 diagnostic and cables that arrived from various eBay sources before and after Christmas. I'll hopefully get that connected up later today and see what it shows. Since I'm still not getting the sound of any fuel pump or relays clicking I wonder if there is anything specific I should be looking for?







Link to comment
Share on other sites

Right. I've managed to get the DiagBox connected up and it seems it's only able to exchange data with the ABS and power steering control units. i.e. it's giving a 'no dialogue' response to everything else, including the BSI body computer and the Injection/Ignition system. Furthermore, and error on the ABS says "Communication fault with engine ECU'. All of which leads me to think I've got some broken connection somewhere that I still haven't found. Any tips very much appreciated!



Link to comment
Share on other sites

You may not be able to easily see a break in a wire, particularly the tiny orange/white one which seems to cause so much trouble. The best method is to run the wire squeezed between thumb and finger tips and feel for any lumps or irregulatities. Even the slightest bump is likely to indicate a break down of the conductor internally, before it becomes visible.


Your symptoms sound so like mine and the other current thread, including the inability to communicate with the EMU and BSI, that I'd be very tempted to run a new earth control wire to replace that orange/white one in its entirety. This is what I had to do anyway following the second occurence of the problem and the second break in that wire. Cut it close to the ECU connector and close to the fuse box and replace it all together and you might just solve all your problems..

Link to comment
Share on other sites



Right, I've been all over those wires again - and the white/orange earth wire in particular. Upshot is I don't think I have the same root cause, though I do seem to have the same final result.


Specifically I traced all the wires in that loom by finger-tip as suggested, but found no issues in any of them. To check in case there was a break inside either of the multi-block connectors themselves, I then semi-disassembled these to get at the wire-end connections themselves. Once I was able to get a multi-meter between the female pin connectors at each end of the wire, it was clear from the nil resistance reading that the wire is fine. I checked the other wires in the same way and also found no resistance issues.


So, the upshot is I think the loom is fine, yet having done all that I am still getting the immobiliser light on, silence from the fuel pump and relays when cranking, and a 'no dialogue' response from the BCI and ECU when DiagBox is connected up.


Obviously I'm slightly losing my patience now (as is her ladyship indoors!), and I'm wondering if the issue is somewhere else - a failed relay or something. Happy for any suggestions as to where to look next!!






Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...