Jump to content

Sargent PX 300 charger


Bazzerk

Recommended Posts

I am trying to work out whether my 2 x 110ah sealed lead acid batteries now 4 years old in my Autocruise Alto are starting to fail or the charger is playing up. I purposely ran the battery bank down to 12.4v from the original standing voltage of 13.1v (compressor fridge) over a couple of days, plugged into ehu to recharge and within 4 hours the charger was down to delivering 0.1amps at 13.5 volts, down from 8amps and 14v at start. There is an led indicator on the charger which is red for stage one and two which turns green at float stage (after four hours). I doubt the charger is capable of fully recharging the batteries in that time.

Any ideas please.

Link to comment
Share on other sites

Not tried charging indivually at the moment, The Sargent unit manual says it is capable of charging upto 220 amps. As I need the 2 batteries to run with compressor fridge for extended off hook up I am trying to resolve with both on board. Batteries where bought together as a matching pair and I will replace both if necessary.

Checked this morning and the charge is still on float. I assume the charger thinks the battery's are fully charged as no amps going in leisure battery. If I switch to charge vehicle battery the amps jump to 6.

Link to comment
Share on other sites

Tried turning on and off and it remains at float. It must think the batteries are fully charged. I can't see it doing that in four hours from approx 50% discharged. It's starting to get a bit chilly maybe that's is affecting how much charge it will take.

Barry.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...