Jump to content

Wiper Arms (3)on Hymers


potjoe

Recommended Posts

I don't know whether this is relevant, but I notice on the MotorHomeFacts forum that there was correspondence about obtaining wiper blades that locked properly into the ends of the Hymer wiper arms (said to be sourced from Volvo).

 

You don't say how old your motorhome is, but three large wipers are going to put a lot of stress on the mechanical operating system. If your Hymer is getting on a bit, I suspect the wiper operating system is where your problem lies.

Link to comment
Share on other sites

I would fully agree with Derek that it is time to take a look at the mechanical aspects of the wiper system, unless you or a previous owner have fitted larger than standard blades which could cause a similar problem. I have problems in the past with wiper blades getting blown off the side of the windscreen on a car I was driving.

Docted

Link to comment
Share on other sites

potjoe - 2008-04-21 6:54 PM Thank you for e/mails back .This is on my New Hymer m-home Reg57 a B544SL the drivers wiper arm blade got stuck with the next one in and that bent the ARM on the one in front of me (the driver) . john

Hi John.

It might be that the actual blades had slipped in their housing. If you look the distance between the actual blades leave little room for error.

I have always checked that each blade is fully pushed into their housing before each journey.

Sorry if this info is a little bit late for your current probs.

Thai

Link to comment
Share on other sites

I can understand the problem because the wiper arms on my 05 Hymer 544 overlap slightly. When I wash the windscreen I have to be careful to put the wipers back in the correct position - the centre one sits lower.

 

I presume your wiper blades are the right length. My driver blade is 22", the other two are 20".

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...