Jump to content

Non-flush problem


Recommended Posts

Sorry to be calling on your help again, but the flush isn't working on our Thetford C200 CWE.


All was well until I think we ran out of water.

I topped it up and added the pink stuff.

However, pressing the button doesn't generate any water.

The pump seems to be working OK (as the noise is just the same as normal).


As there have been a few bits of algae in the tank, I'm wondering if this would either block the

delivery nozzle or the intake of the pump.

Or does the pump ever need priming and if so, how is that done?


I've been on the Thetford website for clues and sent them a message but haven't received any replies from them. So as ever, it's down to the expert knowledge on here to try and get me sorted.


The instruction manual mentions draining down the tank but I can't seem to locate the plug.

Is this on the bottom of the cistern inside the washroom or is it to be found in the cassette housing compartment on the outside of the 'van? :-S

Link to comment
Share on other sites

There is a little rubbery plug at the bottom of the tank inside the compartment on the outside of the van. It is a good idea to arrange something to channel the water away otherwise it pours into the compartment. Interestingly we had exactly the same trouble with our flush not working at the start of last year. I have a bit of small dia plastic tube which fits into the loo flush tube so I can blow it through to remove any obstruction but no go. We went away anyway and when we got there it was working fine. I didn't drain down this winter (we keep a heater in the van) to stop it happening again but by mistake I ran the flush out of water. Refilled but it wouldn't work. Left it for a couple of hours and it worked fine. Haven't a clue why this should be unless the pump needs time to refill/prime itself. It worked for us so try it.
Link to comment
Share on other sites

Graham, thanks for your response.

I discovered it wasn't working (after I'd refilled the tank) on the morning we were to return home.

I did think (and hope) that all the jiggling on the rough roads home may have shifted something.

However, on return it was still the same, as it was just prior to posting this query.


Motorhoming friends visited this afternoon and we obviously discussed the situation.

So, went into the 'van for a demo, pressed the switch and.....

....lo and behold, flush water came forth. :-)


Another one of life's little mysteries.

Just a pity that I still couldn't get the hob to produce a spark though. *-)



Link to comment
Share on other sites

I am glad you have 'solved' it in much the same way as we did. No idea why this should be but I have resolved to never let the tank empty and hopefully all should be ok. By the way I did actually report this at the factory service centre when we had the habitation service done but all I really got was a strange look.
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...