Jump to content

Omnistep Problems


Recommended Posts

As you may guess I'm having a 'fettling' weekend, sorting out all those niggles.


Next on my list is the omnistep, which often won't extend for about half an hour after switching off the engine. When this awful rain stops I'm going to have a go at dismantling it and cleaning/greasing the moving parts.


The step doen't retract when the engine starts, though I'm sure it should. I read somewhere about it being connected to the relay which switches the fridge onto 12V, when the engine comes on. Checked the fridge for 12V operation and that didn't work either!


I found 2 blown fuses a 20A and a 15A and replaced them both. Fridge works but step still doesn't retract automatically.


I also found 2 relays, the same spec and thought one of them may be the culprit. I swapped them over but no change - fridge still works and omnistep won't auto retract.


I rechecked the fuses and they're all ok


I suspect a poor earth now. Or does anyone know any better?

Link to comment
Share on other sites

The Sargent control board in my van (2010 Autocruise) is an EC400. Now I had problems with my omnistep - temperamental...stuck part way out then would not go back in.............


Anyway took it off, dismantled it, cleaned it, silicone spray on moving parts, checked microswitch was working OK, reassembled thinking that'll do it...........WRONG :-(


Anyway turned out to be a faulty polyfuse on the circuit board - whole board replaced under warranty by Sargent.


This polyfuse is apparently meant to trip at 3A. Its self resetting so after a short delay its back to functioning.

The step draws max of 1.5A so there is plenty of headroom but because the polyfuse was faulty it was tripping incorrectly at way below 3A.


There was a batch of faulty polyfuses apparently.........sorry don't know the date range....but might be worth checking with Sargent. They are very helpful




Link to comment
Share on other sites

Hi Tony,


I had the same problem a while back that it wouldn`t work for a while,

after turning the engine off and it could be anything up to half an hour

until it started working again.


The was no pattern, rhyme or reason to it and it did what it wanted

when it wanted.


To cut a long story short it turned out to be 1 of the 2 main

philips screws that hold the arms in place that work the extending

mechanism had come loose.


Because one of them had come loose it then didn`t trip the switch

( you`ll see it inside ) and was causing the problem.


First time i tightened the screw and everything was fine for a few

weeks but then it started to play up again.


When i took the step off again and stripped the box the same screw

had come loose again and this time it had damaged one of the

brushes on the motor, by , i think, not tripping the switch when it

had closed and must have been sending power to the motor

even though it had closed.


What i did was to sort out the brush and when i refit and tightened

the 2 philips screws i used " Lock Thread " and to this day it is

still working as it should ( touch wood ).


You can test everything works OK while it is apart but a word of warning




It closes pretty quickly and HURTS LIKE HELL when it gets a finger.


Hope this helps.





Link to comment
Share on other sites

Well what a pig of a job! I suspect the step had sustained some damage in the past. 2 or the srews on the fromt were not the original ones and the plastic surround was damaged.


I managed to eventually get the facia plate off but couldn't undo the screws on the top at the rear of the step.


I gave the whole thing a liberal spray with WD40 and left it for a while.


Out of curiosity, I decided to try it again - and it works fine!


I believe that WD40 isn't a great lubricant so I'll use some spray grease on it and see if that is any use.


Perhaps the old saying is true - all you need in a tool box is WD40 and Gaffa Tape! (If it should move and it doesn't - use WD40, if it does move and shouldn't - use Gaffa Tape!)

Link to comment
Share on other sites

Looks like it`s coming off then ?


Check the screws Tony.


If you need any parts Hill View Awnings have some

secondhand steps that are keenly priced.


They offered me a secondhand motor and gearbox

for £30 + P&P if i needed one.


New ones are damned expensive.


Good luck and mind your fingers.



P.S. check the brushes on the motor as well, make sure they

are nice and free.

Mine had virtually welded themselves and that didn`t help

much either.

Link to comment
Share on other sites

This is a problem that I have just sorted on an Autotrail Cheyenne 365 and I am sure the cure will be common to many.

I spent many hours tracing lines on the wiring diagram, changed the step relay (without testing it), found and changed a 15amp blown fuse near relays under bonnet, changed alternater field relay as step relay seemed to take its power from there (again without testing).

Still no joy so back to the diagrams and decided problem had to be either the blue / white or the red / blue wires after entering the step.

removed motor cover, noticed switch on left and on checking outside the housing found that the opperating button was stuck in and covered in mud.

I worked the button loose untill it popped out, and Glory be--- it worked.

Obviously this is a limit switch pushed in by the step support arm, most of the time it is depressed when the step is up and easilly sticks with road gritt.

Depressing the switch indicates to the sustem that the step is up, so when it sticks it will not retract on ignition.

I will know where to start looking next time.

I also hope it will help others to waste less time than I did.

P. B


Link to comment
Share on other sites

Thanks for that


Unfortunately I don't have time to take it off before I go away at the weekend. I'll have a look when we get back.


It does sound like it's the switch in the step as it worked (once) after I had sprayed some WD40 into the step. I guess it stuck back in again!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...