Jump to content

Truma Boiler failure


Recommended Posts

I need some advice please. My Truma Boiler has just stopped operating. I purchased my van new in 2003, but the Truma has never been serviced, only inspected and tested. It has never worked on Electric from new, but at the time I didn't need electric, and the dealer was too far away to return to. (I live in North East Scotland, dealer in mid England).

My boiler is either a C3402 or a C6002. (The part number does not make it obvious which one)

The boiler has always worked fine on gas, but now when I turn on the water or heating, the boiler goes through it's electrical cycle, i.e everything clicks as normal, but instead of the gas firing up I just get the red light.

I can't get a service engineer for 3 weeks, so I would like to know if there is anything obvious or simple that I could check? I have checked for gas delivery and this is fine through to the last connection into the boiler. I've also checked the fuse and other 12v circuitry.

I would hate to wait 3 weeks only for the engineer to do something simple and get it working again.

Any technical help would be most appreciated.

Link to comment
Share on other sites

Welcome to the Out&AboutLive forums.


As you say that your Truma appliance should be able to heat air and water via 230V mains electricity, and that your motorhome was bought in 2003, the heater should be a C-6002EH as that was the only model at that time with that capability.


Truma’s instruction documentation can be found here




Operating Instructions for the C-6002EH are here




and there is a trouble-shooting list on Page 15.


Regarding your heater failing to fire up on gas and the red fault-light coming on, the first (obvious) thing to check is the gas feed. Make sure the gas-bottle is turned on and contains plenty of gas. Light all the gas-burner’s on the kitchen’s hob - if all the burners will operate simultaneously at full output, this should indicate that an adequate supply of gas is passing through the regulator. (I note that you say you’ve checked for gas delivery to the last connection to the heater, but I think the ‘hob test’ is still worth doing.)


You could check that there is no obstruction (like a mass of spider-web) in the intake/exhaust trunking leading from the heater to its external cowl, but I suspect that’s not where the problem lies.


As you’ve checked the fuses are OK, there’s the possibility that the heater’s gas-valve is blocked or the gas igniters’ insulation has failed (as happened with a Truma C-3402 I once had) or the heater’s pcb may have developed a fault (not that rare), but such problems will probably need a service engineer to resolve.


(It’s far too late now, but Truma heaters carry their own warranty and (in principle at least) you ought to have been able to get the failure to operate on 230V mains electricity corrected by any Truma service engineer without needing to return the motorhome to the mid-England vendor.)


Link to comment
Share on other sites

Thanks Derek,

I've tried lighting all the gas rings and that works fine. I've also downloaded the instructions for the C-6002EH which you are correct, it is my boiler, but their troubleshooting section give me nothing that I havn't already tried.

I agree in retrospect that I should have had the electrics sorted on the boiler when I first got the Motorhome, but 12 years ago there was not the internet to show the list of engineers as it does now. In those days we had to rely on dealers to pass on information which many were not very good at.

Many thanks for your help though which is appreciated. It looks increasingly like I have to bite the bullet and wait for the engineer to get the time to fix the problem.

Link to comment
Share on other sites

If I remember rightly, it is about 4 years since I had a similar fault.To do a complete reset of the electronics you will have to disconnect the 2 separate 12volt supplys that go to the electronics board on the heater. There are also 1 or 2 fuses on this that need checking on the board as well. Hope this helps.



Link to comment
Share on other sites

No experience of the Truma but a similar problem with an Atwood was because of dirt that reduced the flame size and prevented it from heating the flame sensor causing a shut down. Cleaning fixed it. The Atwood had a sight glass so the flame and spark ingnition could be seen working. Similar symptom and cause on a Electrolux fridge. Cleaning fixed it.


12 years old, it probably has some dirt in there somewhere.


The Truma probably has a trip / reset button for the electric heater. If it does, check it is not tripped.



Link to comment
Share on other sites

  • 2 weeks later...


This topic is now archived and is closed to further replies.

  • Create New...