Jump to content

Thetford C263CSL loo flush stopped working


Recommended Posts



We have a Thetford C263CSL loo in our van and the electric flush has stopped working. It flushes off the main water tank, not a separate loo tank.


If you press the flush button it dribbles out a very small amount of water that barely makes it a cm from the spout. Normally it jets it around the rim.


The flush button does eventually cause the main water pump to kick in but still only dribbles water. The taps/pressure elsewhere are fine.


Doing some Googling, it seems there is an electric valve by the toilet cassette which might be at fault but it’s £63 so just wanted to ask if anyone else has had this problem?


I have checked it’s not a blockage in the pipe as far as I can.





Link to comment
Share on other sites

This Thetford webpage relates to the C263-CSL toilet




Thetford also provides - for non-flushing C263 models - a ‘trouble-shooting’ flow chart (image attached below)


As your 2018 Pilote V600G’s taps show no signs of low water pressure, it may be safely assumed that the motorhome’s fresh-water pump is operating effectively. I don’t know what type of pump your 600G has (submersible or pressure-sensitive) but the fact that continuing to press the toilet’s flush button eventually causes the pump to start suggests that it’s a pressure-sensitive one that’s reacting to a drop in the pressure within the water system.


Dunno the answer - there are on-line reports of poor (or no) flushing of C260 toilets, but these usually involve models that have an integrated water tank with a submersible pump inside it, rather than models where flush-water comes from the leisure-vehicle’s main fresh-water tank.


The electric valve for your 2018 toilet should be Thetford Part Number 23709 that is advertised on-line for £39 upwards. A 'vacuum breaker’ (another suspect?) costs about £15.


Link to comment
Share on other sites



I agree with Derek that it is most likely you have a pressure sensitive pump by the fact repeated pushes of the button eventually trigger the pump to run.


My only other thought is that my mains water fed toilet has a none return valve to prevent reverse flow if the internal valve is opened and the pump is not running so maybe you have one and it has stuck or blocked with limescale?


Another thing to try would be opening a tap to trigger the pump to run and then flushing the toilet.



Link to comment
Share on other sites

I had a similar malfunction with the flush not working on my CBE equipped van.


It transpired that the control panel obviously needed to be switched ON but...also the main lighting circuit needed to be switched ON.


I doubt that on such a new van the electromagnetic valve is faulty. It sounds more like that power is not reaching the valve either because of a poor connection or as described above.

Link to comment
Share on other sites

I am not into the techy stuff but on a simple things first basis muck or swarf either from use or from the build can so easily make a pump play up so before spending any money have you checked the pump inlet and outlet are clear, and any pressure switches and one way valves for detritus as it don't take much to disrupt the flow?
Link to comment
Share on other sites

Thanks for all the replies.


The main water pump is a Pentair Shurflo Model 2095-204-112 but it's working fine.


The van hasn't been used for most of Jan and we did have some 'scum' come out of the bathroom tap and first flush of the toilet so I suspect a blockage. I will check that first.


Thanks again.



Link to comment
Share on other sites

If a Thetford toilet has not been in regular use, it’s commonplace for black algae to grow inside the toilet's water hoses and for black ‘debris’ to be ejected from the flush-nozzle into the toilet bowl when the toilet is next used. This will be the case whether the flush-water is provided from a toilet’s integrated water tank or from the motorhome’s main fresh-water tank. However, as Rob’s toilet has only been out of use for a few weeks (I’m assuming "The van hasn't been used for most of Jan..” means January 2021?!) there should not be sufficiet algae build-up to block the water hoses. It might be worth shoving (say) a length of nylon strimmer-line up through the flush-nozzle just in case, but I doubt that will produce a miracle.


Historically the 12V power-supply to electrically-flushed Thetford toilets was protected by a conventional spade-type fuse located somewhere inside the cassette locker. However C260 toilets evidently have a ‘self-resetting fuse’ that’s mentioned here




And this is another discussion about a non-flushing C260 toilet - the 'cure’ was a replacement circuit board




Standard practice for a motorhome with a SHURflo water-pump and a Thetford toilet connected to the main fresh-water tank would be for the 12V power-supply to the toilet to ‘piggy back’ on the water pump’s 12V supply - so the toilet then won’t flush unless the water pump has been turned on. As Rob has confirmed that the water-pump runs OK, the toilet OUGHT to flush OK.


The first thing to do is to confirm that 12V power is reaching the toilet, and then that water arrives at the toilet when the pump runs.


Thetford warrants its products for three years




but - for obvious reasons - meeting the terms and conditions may be tricky at the moment.

Link to comment
Share on other sites

Spent some more time on this today.


I tried some nylon strimmer-line up through the flush nozzle but only tiny bits of dirt came out.


No fuses anywhere to be seen for the toilet.


Page 2 of the spare parts list here has part number 90717 for the 90-degree valve.



When Googled this equates to this part https://caratech.co.uk/products/thetford-90-degree-toilet-electric-valve-90717 which matches the part fitted. See attached photo.


When I disconnected the wires to this valve, there was no power to the toilet, no cassette missing warning lights or flush light. When I tried unscrewing the hose connector there was plenty of water pressure there as I hadn’t bled the water after turning the pump off!


This does make me think this valve isn’t operating properly because it has power and water pressure?


Link to comment
Share on other sites

Unless you can find a Thetford service centre where the problem might be diagnosed and (possibly) dealt with under warranty




it sounds like you may have to replace the valve and hope that this proves to be successful.


The cheapest 90717 valve I could find offered on-line was here (£48.42 including a delivery charge of £3.50 and VAT)




The 90717 valve is advertised widely (and internationally) on-line, which raises doubts about its longevity.

Link to comment
Share on other sites

In keeping with the spirit of robdav's last line above, I would like to tender the observation that the valve appears to be similar to a washing machine inlet valve. Washing machine valves while commonly of the inline variety, are sometimes used in right angle versions. As 12V is a normal operating voltage for washing machine valves, they could perhaps be a possible alternative?


Washing machine valves are normally 3/4" BSP (about 1" over the thread). Perhaps this valve is only 1/2" BSP (3/4" over thread)?


As regards testing the existing valve, it should be possible to couple it to a garden hose, and energise from a 12V battery. (I am assuming that the threaded end is the inlet.)





Link to comment
Share on other sites

  • 2 weeks later...

Hi All


FIX UPDATE – the new valve arrived today and it turns out the it has an inline filter inside which due to the 90-degree installation position, I hadn’t spotted before (it also needs a pair of long nosed pliers to get it out)


I checked the one in the van and it was totally clogged up. I removed it, cleaned it, replaced, tested the flush, removed and cleaned again, replaced and it now flushes better than it ever has before, even when new.


Now to try and return the new part!


I will attach a photo. New valve shown on left, existing filter on right. Hope it helps someone else out.






Link to comment
Share on other sites

Thanks for the update. Well worth knowing about the filter.


As you said earlier that some ‘scum’ came out of the bathroom tap and from the toilet when you first flushed it, you might want to check the state of the interior your Pilote’s fresh-water tank if that’s practicable.


When I had a problem with my Rapido’s water system I rejigged the connection to its SHURflo water pump. I employed food-quality hose of the make/type that had been used throughout my previous Hobby motorhome’s water system with a hose running from a pick-up point at the bottom of the fresh-water tank’s interior, passing though the tank’s upper surface and on to the pump.


As part of my comprehensive pre-winter draining-down procedure I dry out the fresh-water tank’s interior - fairly easy to do with the Rapido as the tank has two large screw-in inspection hatches.To my surprise, although the tank’s interior surfaces were pristine, the pick-up hose was completely covered with black mould. I don’t fill the tank until shortly before the motorhome is to be used for (say) a fortnight’s trip and I drain the tank soon after we get back. Although the mould was on the outside of the hose, there was no evidence that it was on the inside.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...